Rocksolid Light

Welcome to novaBBS (click a section below)

mail  files  register  nodelist  faq  login

System checkpoint complete.


computers / comp.sys.dec / Re: Anybody using the TI silent 703 terminal

SubjectAuthor
* Anybody using the TI silent 703 terminalJay Cotton
`* Re: Anybody using the TI silent 703 terminalScott Dorsey
 `* Re: Anybody using the TI silent 703 terminalJay Cotton
  +- Re: Anybody using the TI silent 703 terminalScott Dorsey
  +- Re: Anybody using the TI silent 703 terminalDennis Boone
  `* Re: Anybody using the TI silent 703 terminalThree Jeeps
   +- Re: Anybody using the TI silent 703 terminalJay Cotton
   +- Re: Anybody using the TI silent 703 terminalJay Cotton
   `* Re: Anybody using the TI silent 703 terminalScott Dorsey
    `* Re: Anybody using the TI silent 703 terminalJay Cotton
     +- Re: Anybody using the TI silent 703 terminalThree Jeeps
     `* Re: Anybody using the TI silent 703 terminalAndy Valencia
      `* Re: Anybody using the TI silent 703 terminalJay Cotton
       `* Re: Anybody using the TI silent 703 terminalScott Dorsey
        `* Re: Anybody using the TI silent 703 terminalJay Cotton
         `- Re: Anybody using the TI silent 703 terminalJay Cotton

1
Subject: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Sat, 21 Aug 2021 01:41 UTC
X-Received: by 2002:a37:4048:: with SMTP id n69mr11826088qka.261.1629510087834;
Fri, 20 Aug 2021 18:41:27 -0700 (PDT)
X-Received: by 2002:a9d:206a:: with SMTP id n97mr18953337ota.247.1629510087564;
Fri, 20 Aug 2021 18:41:27 -0700 (PDT)
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Fri, 20 Aug 2021 18:41:27 -0700 (PDT)
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.73; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.73
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com>
Subject: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Sat, 21 Aug 2021 01:41:27 +0000
Content-Type: text/plain; charset="UTF-8"
View all headers
I got on on ebay, and of course it's dead.

It will not post.  I looked inside at the main board and there  is an empty
socket U16.  I think this is an eprom.   If any one can confirm my suspicion
that would be very helpful.

I did find a complete schematic for the printer, and am planning a debug
session this weekend.

tnx
jc


Subject: Re: Anybody using the TI silent 703 terminal
From: Scott Dorsey
Newsgroups: comp.sys.dec
Organization: Former users of Netcom shell (1989-2000)
Date: Sat, 21 Aug 2021 14:50 UTC
References: 1
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.panix2.panix.com!panix2.panix.com!not-for-mail
From: klu...@panix.com (Scott Dorsey)
Newsgroups: comp.sys.dec
Subject: Re: Anybody using the TI silent 703 terminal
Date: 21 Aug 2021 14:50:09 -0000
Organization: Former users of Netcom shell (1989-2000)
Lines: 30
Message-ID: <sfr3r1$1se$1@panix2.panix.com>
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com>
Injection-Info: reader1.panix.com; posting-host="panix2.panix.com:166.84.1.2";
logging-data="5401"; mail-complaints-to="abuse@panix.com"
View all headers
In article <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com>,
Jay Cotton  <lbmgmusic@gmail.com> wrote:
I got on on ebay, and of course it's dead.

What does dead mean?  No power light?

It will not post.  I looked inside at the main board and there  is an empty
socket U16.  I think this is an eprom.   If any one can confirm my suspicion
that would be very helpful.

It was not at all unusual for people to design in extra eprom sockets in case
later revisions of the firmware bloated.  If it looks like memory and the
pinout is right, it's likely an eprom but that doesn't mean anything is
missing.

I did find a complete schematic for the printer, and am planning a debug
session this weekend.

Then you should have no problem seeing with U16 is.  The first thing is to
check power supply rails.  It has been 40 years since I have worked on one
of these things but as I recall they have a weird rail for the thermal head.
But if you have no 5V, nothing will work.

As always with equipment of this vintage, suspect electrolytics and tantalum
capacitors before anything else.  Beep out the supply rails before applying
power because shorted tantalums will cause collateral damage.
--scott

--
"C'est un Nagra. C'est suisse, et tres, tres precis."


Subject: Re: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Sun, 22 Aug 2021 18:59 UTC
References: 1 2
X-Received: by 2002:a05:622a:120d:: with SMTP id y13mr27085315qtx.10.1629658742724;
Sun, 22 Aug 2021 11:59:02 -0700 (PDT)
X-Received: by 2002:a05:6808:2084:: with SMTP id s4mr9443264oiw.31.1629658741928;
Sun, 22 Aug 2021 11:59:01 -0700 (PDT)
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Sun, 22 Aug 2021 11:59:01 -0700 (PDT)
In-Reply-To: <sfr3r1$1se$1@panix2.panix.com>
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.73; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.73
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com> <sfr3r1$1se$1@panix2.panix.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Sun, 22 Aug 2021 18:59:02 +0000
Content-Type: text/plain; charset="UTF-8"
View all headers
Here is the situation now.

The power supplies all check out.
The clock circuit is working.  (8.08mhz)
The reset circuit seems to be working.

The processor is dead.  No activity at all.

I tried to find documentation for the TMS 7041 chip.
No luck there.

Kinda stuck at this point.

jc


Subject: Re: Anybody using the TI silent 703 terminal
From: Scott Dorsey
Newsgroups: comp.sys.dec
Organization: Former users of Netcom shell (1989-2000)
Date: Sun, 22 Aug 2021 19:22 UTC
References: 1 2 3
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.panix2.panix.com!panix2.panix.com!not-for-mail
From: klu...@panix.com (Scott Dorsey)
Newsgroups: comp.sys.dec
Subject: Re: Anybody using the TI silent 703 terminal
Date: 22 Aug 2021 19:22:08 -0000
Organization: Former users of Netcom shell (1989-2000)
Lines: 24
Message-ID: <sfu850$2am$1@panix2.panix.com>
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com> <sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
Injection-Info: reader1.panix.com; posting-host="panix2.panix.com:166.84.1.2";
logging-data="11448"; mail-complaints-to="abuse@panix.com"
View all headers
Jay Cotton  <lbmgmusic@gmail.com> wrote:
Here is the situation now.

The power supplies all check out.
The clock circuit is working.  (8.08mhz)
The reset circuit seems to be working.

The processor is dead.  No activity at all.

So the buss isn't cycling?  Do you see anything moving on the buss at all?

I tried to find documentation for the TMS 7041 chip.
No luck there.

There should be a TMS7000 databook online somewhere.  There are various
different versions of the IC... I don't remember the difference between
the TMS7041 and TMS7040 offhand but the databook will tell you.  It was
not one of the more popular microcontrollers but they were certainly out
there.

Do you have a logic analyzer?
--scott
--
"C'est un Nagra. C'est suisse, et tres, tres precis."


Subject: Re: Anybody using the TI silent 703 terminal
From: Dennis Boone
Newsgroups: comp.sys.dec
Date: Sun, 22 Aug 2021 20:13 UTC
References: 1 2 3
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!feeder1.feed.usenet.farm!feed.usenet.farm!newsfeed.xs4all.nl!newsfeed9.news.xs4all.nl!news-out.netnews.com!news.alt.net!fdc3.netnews.com!peer01.ams1!peer.ams1.xlned.com!news.xlned.com!peer01.iad!feed-me.highwinds-media.com!news.highwinds-media.com!border1.nntp.dca1.giganews.com!nntp.giganews.com!buffer1.nntp.dca1.giganews.com!news.giganews.com.POSTED!not-for-mail
NNTP-Posting-Date: Sun, 22 Aug 2021 15:13:10 -0500
Sender: Dennis Boone <drb@yagi.h-net.org>
From: drb...@ihatespam.msu.edu (Dennis Boone)
Subject: Re: Anybody using the TI silent 703 terminal
Newsgroups: comp.sys.dec
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com> <sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
User-Agent: tin/2.4.5-20201224 ("Glen Albyn") (FreeBSD/12.2-RELEASE-p6 (amd64))
Message-ID: <Uvmdnfjq_fJLMr_8nZ2dnUU7-dGdnZ2d@giganews.com>
Date: Sun, 22 Aug 2021 15:13:10 -0500
Lines: 5
X-Usenet-Provider: http://www.giganews.com
X-Trace: sv3-XaOeB5XNth9y0UP3ZliLgjPWWAbko827YmSOMYEyj9oppN7pNswXdvBXLESgjV/GviEfYYwuyYFemeN!k4ZtWlHerl4B4ZDKSSmwbgHw61FOaLc4L+OvXr1x65OYSBH9jbCWF5GutsxyTsj4OeAJvdU=
X-Complaints-To: abuse@giganews.com
X-DMCA-Notifications: http://www.giganews.com/info/dmca.html
X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your complaint properly
X-Postfilter: 1.3.40
X-Original-Bytes: 1294
X-Received-Bytes: 1473
View all headers
 > I tried to find documentation for the TMS 7041 chip.

http://bitsavers.org/components/ti/TMS7000/1983_SPND001A_TI_TMS7000_Family_Data_Manual.pdf

De


Subject: Re: Anybody using the TI silent 703 terminal
From: Three Jeeps
Newsgroups: comp.sys.dec
Date: Mon, 23 Aug 2021 02:03 UTC
References: 1 2 3
X-Received: by 2002:aed:20a2:: with SMTP id 31mr27898649qtb.69.1629684224237;
Sun, 22 Aug 2021 19:03:44 -0700 (PDT)
X-Received: by 2002:a9d:6b84:: with SMTP id b4mr11755838otq.294.1629684223873;
Sun, 22 Aug 2021 19:03:43 -0700 (PDT)
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Sun, 22 Aug 2021 19:03:43 -0700 (PDT)
In-Reply-To: <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
Injection-Info: google-groups.googlegroups.com; posting-host=72.65.247.150; posting-account=dVth5woAAACPBHbCgqHi-BCdzU6kMrBw
NNTP-Posting-Host: 72.65.247.150
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com>
<sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: jjhud...@gmail.com (Three Jeeps)
Injection-Date: Mon, 23 Aug 2021 02:03:44 +0000
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
View all headers
On Sunday, August 22, 2021 at 2:59:03 PM UTC-4, lbmg...@gmail.com wrote:
Here is the situation now.

The power supplies all check out.
The clock circuit is working. (8.08mhz)
The reset circuit seems to be working.

The processor is dead. No activity at all.

I tried to find documentation for the TMS 7041 chip.
No luck there.

Kinda stuck at this point.

jc
A quick read of the databook indicates that the CPU clock is suppose to be 2.5 MHz across pins 17,18.  If the 8 Mhz is at the CPU clock pins, that is high. For processors of that era I would do o/c experiments and they usually fell apart around 105% of spec.   Perhaps the reset line is frozen? Any activity on the address, data or r/w lines?  Processor socketed?  As asked earlier, got a logic analyzer?
J


Subject: Re: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Mon, 23 Aug 2021 04:42 UTC
References: 1 2 3 4
X-Received: by 2002:a37:634d:: with SMTP id x74mr19141736qkb.453.1629693775419;
Sun, 22 Aug 2021 21:42:55 -0700 (PDT)
X-Received: by 2002:a05:6830:1f54:: with SMTP id u20mr25998084oth.320.1629693775099;
Sun, 22 Aug 2021 21:42:55 -0700 (PDT)
Path: i2pn2.org!i2pn.org!news.niel.me!usenet.pasdenom.info!usenet-fr.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Sun, 22 Aug 2021 21:42:54 -0700 (PDT)
In-Reply-To: <99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com>
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.73; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.73
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com>
<sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
<99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <1b6e7363-c09f-4274-8086-ccf397688177n@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Mon, 23 Aug 2021 04:42:55 +0000
Content-Type: text/plain; charset="UTF-8"
View all headers
Several things pop out as I read through the data book.

1.  4k rom on board, and 128 bytes of ram on board the chip.
2.  It is possible that the chip is looping on its internal code/ram polling a status
bit/byte before moving on to the next phase.
3.  The 8Mhz clock is way high, and 2.5mhz is more likely.  Need to drill in on that.
A side note here, things like clock into the chip come from a gate array, where the 8mhz crystal
is connected.

4. need to revisit the clock pins and document each one.
5.  need to take a better look at the reset pin.  wonder if reset is dodgy.


Subject: Re: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Mon, 23 Aug 2021 04:46 UTC
References: 1 2 3 4
X-Received: by 2002:ac8:7304:: with SMTP id x4mr27759152qto.222.1629693977441;
Sun, 22 Aug 2021 21:46:17 -0700 (PDT)
X-Received: by 2002:aca:d02:: with SMTP id 2mr10509920oin.126.1629693977146;
Sun, 22 Aug 2021 21:46:17 -0700 (PDT)
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!news.snarked.org!border2.nntp.dca1.giganews.com!nntp.giganews.com!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Sun, 22 Aug 2021 21:46:16 -0700 (PDT)
In-Reply-To: <99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com>
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.73; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.73
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com>
<sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
<99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <edf6bd32-07e1-4a4a-ab58-e7f28bef924bn@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Mon, 23 Aug 2021 04:46:17 +0000
Content-Type: text/plain; charset="UTF-8"
Lines: 7
View all headers
Yes I have a logic analyzer (8 channels).

All of the chips are directly soldered to the board. With exception of U16.

No action on the address/data or r/w lines.   But then the chip may be running internal code that is polling at I/O port
somewhere.

jc


Subject: Re: Anybody using the TI silent 703 terminal
From: Scott Dorsey
Newsgroups: comp.sys.dec
Organization: Former users of Netcom shell (1989-2000)
Date: Mon, 23 Aug 2021 18:17 UTC
References: 1 2 3 4
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.panix2.panix.com!panix2.panix.com!not-for-mail
From: klu...@panix.com (Scott Dorsey)
Newsgroups: comp.sys.dec
Subject: Re: Anybody using the TI silent 703 terminal
Date: 23 Aug 2021 18:17:09 -0000
Organization: Former users of Netcom shell (1989-2000)
Lines: 9
Message-ID: <sg0on5$s3h$1@panix2.panix.com>
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com> <sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com> <99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com>
Injection-Info: reader2.panix.com; posting-host="panix2.panix.com:166.84.1.2";
logging-data="1568"; mail-complaints-to="abuse@panix.com"
View all headers
Three Jeeps  <jjhudak4@gmail.com> wrote:
A quick read of the databook indicates that the CPU clock is suppose to be =
2.5 MHz across pins 17,18.  If the 8 Mhz is at the CPU clock pins, that is =
high.

Could be bad crystal.  More likely bad decoupling capacitors on supply rails.
--scott
--
"C'est un Nagra. C'est suisse, et tres, tres precis."


Subject: Re: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Mon, 23 Aug 2021 22:14 UTC
References: 1 2 3 4 5
X-Received: by 2002:a05:620a:1009:: with SMTP id z9mr19608769qkj.483.1629756845719; Mon, 23 Aug 2021 15:14:05 -0700 (PDT)
X-Received: by 2002:a05:6830:3114:: with SMTP id b20mr26162308ots.17.1629756845369; Mon, 23 Aug 2021 15:14:05 -0700 (PDT)
Path: i2pn2.org!rocksolid2!i2pn.org!aioe.org!news.uzoreto.com!tr3.eu1.usenetexpress.com!feeder.usenetexpress.com!tr3.iad1.usenetexpress.com!border1.nntp.dca1.giganews.com!nntp.giganews.com!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Mon, 23 Aug 2021 15:14:05 -0700 (PDT)
In-Reply-To: <sg0on5$s3h$1@panix2.panix.com>
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.73; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.73
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com> <sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com> <99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com> <sg0on5$s3h$1@panix2.panix.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Mon, 23 Aug 2021 22:14:05 +0000
Content-Type: text/plain; charset="UTF-8"
Lines: 13
View all headers
Page 4-27 lists the max clockin to be 10.2 mhz.  The CPU has an internal divide by
4 circuit.   I guess the 8mhz clock is o.k.

Probing with a scope.

I see pin13 has (INT1)  76hz.  It seems to conform to the description in the terminal manual.

No data buss or address buss action at all.   The MC bit is 0,  as documented in the terminal
manual, for full expansion mode.

Reset is a 1.  I blipped it with a ground, and did not see any changes at all.

Here is an interesting point.  The CLOCKOUT pin 2 is a .  No clock.  This may be set by the boot
ROM.


Subject: Re: Anybody using the TI silent 703 terminal
From: Three Jeeps
Newsgroups: comp.sys.dec
Date: Tue, 24 Aug 2021 01:44 UTC
References: 1 2 3 4 5 6
X-Received: by 2002:a37:607:: with SMTP id 7mr24783602qkg.0.1629769481713;
Mon, 23 Aug 2021 18:44:41 -0700 (PDT)
X-Received: by 2002:a9d:206a:: with SMTP id n97mr29758410ota.247.1629769481432;
Mon, 23 Aug 2021 18:44:41 -0700 (PDT)
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Mon, 23 Aug 2021 18:44:41 -0700 (PDT)
In-Reply-To: <bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com>
Injection-Info: google-groups.googlegroups.com; posting-host=72.65.247.150; posting-account=dVth5woAAACPBHbCgqHi-BCdzU6kMrBw
NNTP-Posting-Host: 72.65.247.150
References: <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com>
<sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com>
<99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com> <sg0on5$s3h$1@panix2.panix.com>
<bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <3cb32e1f-633d-439b-9507-2c980caffb3en@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: jjhud...@gmail.com (Three Jeeps)
Injection-Date: Tue, 24 Aug 2021 01:44:41 +0000
Content-Type: text/plain; charset="UTF-8"
View all headers
On Monday, August 23, 2021 at 6:14:06 PM UTC-4, lbmg...@gmail.com wrote:
Page 4-27 lists the max clockin to be 10.2 mhz. The CPU has an internal divide by
4 circuit. I guess the 8mhz clock is o.k.

Probing with a scope.

I see pin13 has (INT1) 76hz. It seems to conform to the description in the terminal manual.

No data buss or address buss action at all. The MC bit is 0, as documented in the terminal
manual, for full expansion mode.

Reset is a 1. I blipped it with a ground, and did not see any changes at all.

Here is an interesting point. The CLOCKOUT pin 2 is a . No clock. This may be set by the boot
ROM.
I looked in the data book to see if the clk had a divider ckt but didn't find any.  If you found one then ya, 8MHz would put it into specs.  U16 is the processor? or the ROM?  I am not at all familar with the thing you are working on.
I quickly gleaned that on startup the CPU does a data fetch at FFFF,FFFE for boot sequence  and yet you dont see any bus activity?  I'd have to read more about how the CPU operates to offer help.
I did a quick google search and sources of that chip seem to be long gone.  I did come across a ref to Toshiba as a second source but had no luck finding  any.  
J



Subject: Re: Anybody using the TI silent 703 terminal
From: Andy Valencia
Newsgroups: comp.sys.dec
Date: Tue, 24 Aug 2021 04:30 UTC
References: 1 2 3 4 5 6 7
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!news.mixmin.net!news2.arglkargh.de!news.karotte.org!fu-berlin.de!uni-berlin.de!individual.net!not-for-mail
From: van...@vsta.org (Andy Valencia)
Newsgroups: comp.sys.dec
Subject: Re: Anybody using the TI silent 703 terminal
Date: Mon, 23 Aug 2021 21:30:33 -0700
Lines: 11
Message-ID: <162977943325.15221.16850123742808301757@media.vsta.org>
References: <3cb32e1f-633d-439b-9507-2c980caffb3en@googlegroups.com> <e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com> <sfr3r1$1se$1@panix2.panix.com> <56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com> <99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com> <sg0on5$s3h$1@panix2.panix.com> <bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com>
X-Trace: individual.net uls1wvhKOW+Z8GkGsWRE2Aivtdp6G8BhXUyiwSqVGQdyMELULK
X-Orig-Path: media
Cancel-Lock: sha1:PGwajmcg8J3KoEje99zVqOAiZy0=
User-Agent: rn.py v0.0.1
View all headers
Three Jeeps <jjhudak4@gmail.com> writes:
I quickly gleaned that on startup the CPU does a data fetch at FFFF,FFFE
for boot sequence  and yet you dont see any bus activity?

I feel like he should at least see the reset line blip on powerup.
Without that, it seems like something basic upstream has failed.  As
somebody said, caps on the power rails, something like that.

Andy Valencia
Home page: https://www.vsta.org/andy/
To contact me: https://www.vsta.org/contact/andy.html


Subject: Re: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Tue, 24 Aug 2021 18:50 UTC
References: 1 2 3 4 5 6 7 8
X-Received: by 2002:a37:b686:: with SMTP id g128mr27596479qkf.68.1629831004445;
Tue, 24 Aug 2021 11:50:04 -0700 (PDT)
X-Received: by 2002:a05:6830:130f:: with SMTP id p15mr27025145otq.109.1629831004136;
Tue, 24 Aug 2021 11:50:04 -0700 (PDT)
Path: i2pn2.org!i2pn.org!usenet.goja.nl.eu.org!3.eu.feeder.erje.net!feeder.erje.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Tue, 24 Aug 2021 11:50:03 -0700 (PDT)
In-Reply-To: <162977943325.15221.16850123742808301757@media.vsta.org>
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.73; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.73
References: <3cb32e1f-633d-439b-9507-2c980caffb3en@googlegroups.com>
<e722dd86-3b20-47a9-bc96-782e4b42f5efn@googlegroups.com> <sfr3r1$1se$1@panix2.panix.com>
<56112a69-7f35-4c3f-b5c3-0cb488725a4bn@googlegroups.com> <99555a99-ec57-44f7-9cd5-fea0adecc2b0n@googlegroups.com>
<sg0on5$s3h$1@panix2.panix.com> <bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com>
<162977943325.15221.16850123742808301757@media.vsta.org>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <b4c2a289-4f59-4e67-a2d2-23d0ef78ac42n@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Tue, 24 Aug 2021 18:50:04 +0000
Content-Type: text/plain; charset="UTF-8"
View all headers
My next official step will be to replace the power supply caps.
I doubt that this is the primary problem, but its not that hard to do.

WRT reset.  The reset goes to a 1 after the power is applied.  I have
not measured the delay.  Should be about 500 usec after the power
rails are stable.  Controlled by a custom package (why oh why)  lm3905 timer.

WRT memory read at init.  I will setup the analyzer and try to catch that. 
Guess I will trigger on the rising edge of reset. 


Subject: Re: Anybody using the TI silent 703 terminal
From: Scott Dorsey
Newsgroups: comp.sys.dec
Organization: Former users of Netcom shell (1989-2000)
Date: Thu, 26 Aug 2021 01:49 UTC
References: 1 2 3 4
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.panix2.panix.com!panix2.panix.com!not-for-mail
From: klu...@panix.com (Scott Dorsey)
Newsgroups: comp.sys.dec
Subject: Re: Anybody using the TI silent 703 terminal
Date: 26 Aug 2021 01:49:22 -0000
Organization: Former users of Netcom shell (1989-2000)
Lines: 14
Message-ID: <sg6rv2$h1i$1@panix2.panix.com>
References: <3cb32e1f-633d-439b-9507-2c980caffb3en@googlegroups.com> <bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com> <162977943325.15221.16850123742808301757@media.vsta.org> <b4c2a289-4f59-4e67-a2d2-23d0ef78ac42n@googlegroups.com>
Injection-Info: reader1.panix.com; posting-host="panix2.panix.com:166.84.1.2";
logging-data="632"; mail-complaints-to="abuse@panix.com"
View all headers
Jay Cotton  <lbmgmusic@gmail.com> wrote:
My next official step will be to replace the power supply caps.
I doubt that this is the primary problem, but its not that hard to do.

That's not what I said.  Check the decoupling capacitors on the logic.

It probably won't hurt to do the power supply caps in the process, mind you,
since they are almost certainly bad.  But it's the logic decoupling that
may be keeping the processor from running right.
--scott


--
"C'est un Nagra. C'est suisse, et tres, tres precis."


Subject: Re: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Thu, 26 Aug 2021 02:09 UTC
References: 1 2 3 4 5
X-Received: by 2002:ac8:4b4c:: with SMTP id e12mr1231154qts.193.1629943796950;
Wed, 25 Aug 2021 19:09:56 -0700 (PDT)
X-Received: by 2002:aca:ea8b:: with SMTP id i133mr9174201oih.25.1629943796628;
Wed, 25 Aug 2021 19:09:56 -0700 (PDT)
Path: i2pn2.org!i2pn.org!paganini.bofh.team!usenet.pasdenom.info!usenet-fr.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Wed, 25 Aug 2021 19:09:56 -0700 (PDT)
In-Reply-To: <sg6rv2$h1i$1@panix2.panix.com>
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.169; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.169
References: <3cb32e1f-633d-439b-9507-2c980caffb3en@googlegroups.com>
<bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com> <162977943325.15221.16850123742808301757@media.vsta.org>
<b4c2a289-4f59-4e67-a2d2-23d0ef78ac42n@googlegroups.com> <sg6rv2$h1i$1@panix2.panix.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <70d215ad-9c49-4e41-8c29-c93464c02781n@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Thu, 26 Aug 2021 02:09:56 +0000
Content-Type: text/plain; charset="UTF-8"
View all headers
Well, I am seeing a bit of racket on the +5 rail.  So, a few bucks for caps seems
in order.

Bypass caps eh?  I'll have a go at them also, the the power supply caps come in.

jc


Subject: Re: Anybody using the TI silent 703 terminal
From: Jay Cotton
Newsgroups: comp.sys.dec
Date: Thu, 9 Dec 2021 02:33 UTC
References: 1 2 3 4 5 6
X-Received: by 2002:a05:620a:bc8:: with SMTP id s8mr11085164qki.367.1639017222692;
Wed, 08 Dec 2021 18:33:42 -0800 (PST)
X-Received: by 2002:a9d:550c:: with SMTP id l12mr3123821oth.69.1639017222230;
Wed, 08 Dec 2021 18:33:42 -0800 (PST)
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!news.misty.com!border2.nntp.dca1.giganews.com!nntp.giganews.com!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.sys.dec
Date: Wed, 8 Dec 2021 18:33:41 -0800 (PST)
In-Reply-To: <70d215ad-9c49-4e41-8c29-c93464c02781n@googlegroups.com>
Injection-Info: google-groups.googlegroups.com; posting-host=206.214.236.73; posting-account=cm3czgoAAACZtaQ6RHlLEIj6C6dsES7I
NNTP-Posting-Host: 206.214.236.73
References: <3cb32e1f-633d-439b-9507-2c980caffb3en@googlegroups.com>
<bdf6ce55-f021-40fa-b0f1-f08101aeec2en@googlegroups.com> <162977943325.15221.16850123742808301757@media.vsta.org>
<b4c2a289-4f59-4e67-a2d2-23d0ef78ac42n@googlegroups.com> <sg6rv2$h1i$1@panix2.panix.com>
<70d215ad-9c49-4e41-8c29-c93464c02781n@googlegroups.com>
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <44829290-b401-417d-ab09-f4f333ae5d96n@googlegroups.com>
Subject: Re: Anybody using the TI silent 703 terminal
From: lbmgmu...@gmail.com (Jay Cotton)
Injection-Date: Thu, 09 Dec 2021 02:33:42 +0000
Content-Type: text/plain; charset="UTF-8"
Lines: 19
View all headers
On Wednesday, August 25, 2021 at 7:09:57 PM UTC-7, Jay Cotton wrote:
Well, I am seeing a bit of racket on the +5 rail. So, a few bucks for caps seems
in order.

Bypass caps eh? I'll have a go at them also, the the power supply caps come in.

jc
Closing out this discussion.

I did not get the 703 running, changing caps was not the solution.  I suspect it may have had a
voltage spike or the wrong power supply attached or something like that.

However, this turns out not to be a complete disaster.  I got another 703 (that works) and now I have
a source of parts for the running terminal.

For those interested, https://www.youtube.com/c/CuriousMarc has a series on the silent 703 that is
very interesting.  Not to mention the resurrection of the Apollo guidance computer etc.


jc


1
rocksolid light 0.7.2
clearneti2ptor