Rocksolid Light

Welcome to novaBBS (click a section below)

mail  files  register  nodelist  faq  login

Any given program will expand to fill available memory.


computers / comp.graphics.apps.gnuplot / Re: GNUplot for hysteresis loop not giving graph

SubjectAuthor
* GNUplot for hysteresis loop not giving graphBuse Ozkan
`- Re: GNUplot for hysteresis loop not giving graphJörg_Buchholz

1
Subject: GNUplot for hysteresis loop not giving graph
From: Buse Ozkan
Newsgroups: comp.graphics.apps.gnuplot
Date: Wed, 16 Dec 2020 13:20 UTC
X-Received: by 2002:ac8:2a8f:: with SMTP id b15mr33211971qta.33.1608124848325;
Wed, 16 Dec 2020 05:20:48 -0800 (PST)
X-Received: by 2002:a5b:908:: with SMTP id a8mr51152198ybq.11.1608124848086;
Wed, 16 Dec 2020 05:20:48 -0800 (PST)
Path: i2pn2.org!i2pn.org!weretis.net!feeder8.news.weretis.net!proxad.net!feeder1-2.proxad.net!209.85.160.216.MISMATCH!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.graphics.apps.gnuplot
Date: Wed, 16 Dec 2020 05:20:47 -0800 (PST)
Complaints-To: groups-abuse@google.com
Injection-Info: google-groups.googlegroups.com; posting-host=212.175.114.41; posting-account=DeUp5QoAAACdiVgdsdjjlweW2zf_oItN
NNTP-Posting-Host: 212.175.114.41
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <be92635d-90e5-4a38-8eb4-df148821352en@googlegroups.com>
Subject: GNUplot for hysteresis loop not giving graph
From: buse1.oz...@gmail.com (Buse Ozkan)
Injection-Date: Wed, 16 Dec 2020 13:20:48 +0000
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
View all headers
Hi All,

I am a PhD student in The University of Sheffield which involves doing micromagnetic simulations and drawing hysteresis loops which would take place via using NMAG package.

However, when I follow the instructions and tutorials in the manual makeplot.gnu is not working when I searched the error to draw it with my data - doing the simple hysteresis loop example the plot.dat - an empty plot is created.

where no loop is generated like there is no data in the file.
(I have changed the file name from plot.dat to plot1.dat)

I have tried the following:
gnuplot --persist -e 'plot "plot1.dat" u 1:2'

gnuplot make_plot.gnu
where the make_plot.gnu is a script with;
set term postscript eps enhanced color
set out ‘hysteresis.eps’
set xlabel ‘Applied field H_x   (A/m)’
set ylabel ‘M_x / M_s’
set xrange [-1050000:1050000]
set yrange [-1.2:1.2]
plot ‘plot.dat’ u 1:2 ti ‘ellipsoid example’ w lp 3


Is there any help you can give me about this?
Also apart from the manuals are there any other tutorials present for me to understand the package more to use it effectively?

Waiting for your reply
Best wishes,
Buse OZKAN


Subject: Re: GNUplot for hysteresis loop not giving graph
From: Jörg_Buchholz
Newsgroups: comp.graphics.apps.gnuplot
Organization: A noiseless patient Spider
Date: Thu, 17 Dec 2020 08:16 UTC
References: 1
Path: i2pn2.org!i2pn.org!eternal-september.org!reader02.eternal-september.org!.POSTED!not-for-mail
From: bookwood...@freenet.de (Jörg_Buchholz)
Newsgroups: comp.graphics.apps.gnuplot
Subject: Re: GNUplot for hysteresis loop not giving graph
Date: Thu, 17 Dec 2020 09:16:35 +0100
Organization: A noiseless patient Spider
Lines: 23
Message-ID: <rrf451$6ae$1@dont-email.me>
References: <be92635d-90e5-4a38-8eb4-df148821352en@googlegroups.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit
Injection-Date: Thu, 17 Dec 2020 08:16:33 -0000 (UTC)
Injection-Info: reader02.eternal-september.org; posting-host="1c03387bb53f102d593c609a5faa34b2";
logging-data="6478"; mail-complaints-to="abuse@eternal-september.org"; posting-account="U2FsdGVkX19NZN6B00sbjjMJLS06gINfDj2gIkUrnAQ="
User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:78.0) Gecko/20100101
Thunderbird/78.6.0
Cancel-Lock: sha1:WUSPqwnt2WbcTjvdRSMD1S8/Abc=
In-Reply-To: <be92635d-90e5-4a38-8eb4-df148821352en@googlegroups.com>
Content-Language: en-GB
View all headers
On 16.12.2020 14:20, Buse Ozkan wrote:
I have tried the following: gnuplot --persist -e 'plot "plot1.dat" u
1:2'

gnuplot make_plot.gnu where the make_plot.gnu is a script with; set
term postscript eps enhanced color set out ‘hysteresis.eps’ set
xlabel ‘Applied field H_x   (A/m)’ set ylabel ‘M_x / M_s’ set xrange
[-1050000:1050000] set yrange [-1.2:1.2] plot ‘plot.dat’ u 1:2 ti
‘ellipsoid example’ w lp 3


Is there any help you can give me about this? Also apart from the
manuals are there any other tutorials present for me to understand
the package more to use it effectively?

If you first open gnuplot and then load the script you get error
messages from gnuplot.

load 'make_plot.gnu'


Jörg



1
rocksolid light 0.7.2
clearneti2ptor