Rocksolid Light

Welcome to novaBBS (click a section below)

mail  files  register  nodelist  faq  login

As Will Rogers would have said, "There is no such things as a free variable."


computers / comp.text.tex / beamer warsawtheme: header navigation is off by 1

SubjectAuthor
* beamer warsawtheme: header navigation is off by 1Sivaram Neelakantan
`* Re: beamer warsawtheme: header navigation is off by 1Axel Berger
 `* Re: beamer warsawtheme: header navigation is off by 1Sivaram Neelakantan
  `* Re: beamer warsawtheme: header navigation is off by 1Ulrike Fischer
   +- Re: beamer warsawtheme: header navigation is off by 1Axel Berger
   +- Re: beamer warsawtheme: header navigation is off by 1Sivaram Neelakantan
   `- Re: beamer warsawtheme: header navigation is off by 1Sivaram Neelakantan

1
Subject: beamer warsawtheme: header navigation is off by 1
From: Sivaram Neelakantan
Newsgroups: comp.text.tex
Organization: A noiseless patient Spider
Date: Sun, 1 May 2022 18:47 UTC
Path: i2pn2.org!i2pn.org!eternal-september.org!reader02.eternal-september.org!.POSTED!not-for-mail
From: nsivaram...@gmail.com (Sivaram Neelakantan)
Newsgroups: comp.text.tex
Subject: beamer warsawtheme: header navigation is off by 1
Date: Mon, 02 May 2022 00:17:47 +0530
Organization: A noiseless patient Spider
Lines: 29
Message-ID: <851qxdnl7w.fsf@gmail.com>
Mime-Version: 1.0
Content-Type: text/plain
Injection-Info: reader02.eternal-september.org; posting-host="57895d025439569ad328c0693d3e985b";
logging-data="14899"; mail-complaints-to="abuse@eternal-september.org"; posting-account="U2FsdGVkX19EfF7KzKSr80qsppXfiA2SJfyUpQIUEWE="
User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (windows-nt)
Cancel-Lock: sha1:b/IcfUw32r/xlKcO/MnSe5Zy6GE=
sha1:lNBJ4In0iNVwX0sBeKRLcYCtzgc=
User-Mail-Address: nsivaram.net@gmail.com
View all headers

I have been using the same beamer tex file for some time and I just
noticed the top navigation sections with the round dots are off by a
section.

The slides looks like this, with 3 sections with 2, 3, 2 slides in each
section

Intro      Compute     Data 
00         000         00   

After pdf generation, the sections light up correctly as I navigate
each slide but the dots below light up in the previous section.  Like,
if I'm in compute section (which is lighted up), slide 1, the dot below
intro lights up.  Which is incorrect, the one below Compute should
light up.

I deleted the *.aux files and tried both within Auctex and commandline
'pdflatex file' but there's no change.  I usually run pdflatex twice
at least when I add some text.

Also I use \include immediately under \section to keep the main file
tidy.


Where should I start looking? 

sivaram
--


Subject: Re: beamer warsawtheme: header navigation is off by 1
From: Axel Berger
Newsgroups: comp.text.tex
Date: Sun, 1 May 2022 22:28 UTC
References: 1
Path: i2pn2.org!i2pn.org!news.swapon.de!fu-berlin.de!uni-berlin.de!individual.net!not-for-mail
From: Spa...@Berger-Odenthal.De (Axel Berger)
Newsgroups: comp.text.tex
Subject: Re: beamer warsawtheme: header navigation is off by 1
Date: Mon, 02 May 2022 00:28:06 +0200
Lines: 12
Message-ID: <626F0976.3B959195@Berger-Odenthal.De>
References: <851qxdnl7w.fsf@gmail.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: quoted-printable
X-Trace: individual.net 2mb0Sr/+fsHKyCq96oSCTQ5k1GcldgPmMas3OL4w8vXMLVZh/f
Cancel-Lock: sha1:uDUUCCBvcySa01No/PICdfpPzgM=
X-Mailer: Mozilla 4.8 [en] (Win98; U)
X-Accept-Language: en,de,nl,es,fr
View all headers
Sivaram Neelakantan wrote:
Also I use \include immediately under \section

Try \input. I'm surprised \include works here at all.


--
/¯\   No  |    Dipl.-Ing. F. Axel Berger    Tel: +49/ 221/ 7771 8067
\ /  HTML |    Roald-Amundsen-Straße 2a     Fax: +49/ 221/ 7771 8069
 X    in  |    D-50829 Köln-Ossendorf      http://berger-odenthal.de
/ \  Mail | -- No unannounced, large, binary attachments, please! --


Subject: Re: beamer warsawtheme: header navigation is off by 1
From: Sivaram Neelakantan
Newsgroups: comp.text.tex
Organization: A noiseless patient Spider
Date: Mon, 2 May 2022 03:06 UTC
References: 1 2
Path: i2pn2.org!i2pn.org!eternal-september.org!reader02.eternal-september.org!.POSTED!not-for-mail
From: nsivaram...@gmail.com (Sivaram Neelakantan)
Newsgroups: comp.text.tex
Subject: Re: beamer warsawtheme: header navigation is off by 1
Date: Mon, 02 May 2022 08:36:43 +0530
Organization: A noiseless patient Spider
Lines: 18
Message-ID: <85sfpsmy4c.fsf@gmail.com>
References: <851qxdnl7w.fsf@gmail.com> <626F0976.3B959195@Berger-Odenthal.De>
Mime-Version: 1.0
Content-Type: text/plain
Injection-Info: reader02.eternal-september.org; posting-host="683c7d1c30f9fe06f6b40a2b86ab9b93";
logging-data="18653"; mail-complaints-to="abuse@eternal-september.org"; posting-account="U2FsdGVkX1/V1mp5Avtqg7sy6VExClNb0VZHB4Gsy2Q="
User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (windows-nt)
Cancel-Lock: sha1:a7s85H/1dCWQ05/OxTuqD5M8WrU=
sha1:p8DR/RdimQxEviq9D++uSgMKlyE=
User-Mail-Address: nsivaram.net@gmail.com
View all headers
On Mon, May 02 2022,Axel Berger wrote:

Sivaram Neelakantan wrote:
Also I use \include immediately under \section

Try \input. I'm surprised \include works here at all.

Thank you!  It got fixed.  I've been using \include via auctex as it
seems to give the right prompts to include other tex files.  A quick
check on google shows this

https://tex.stackexchange.com/questions/246/when-should-i-use-input-vs-include

which doesn't seem to show anything that would cause this issue.  What
was going on then?

sivaram
--


Subject: Re: beamer warsawtheme: header navigation is off by 1
From: Ulrike Fischer
Newsgroups: comp.text.tex
Date: Mon, 2 May 2022 07:18 UTC
References: 1 2 3
Path: i2pn2.org!i2pn.org!news.swapon.de!fu-berlin.de!uni-berlin.de!individual.net!not-for-mail
From: new...@nililand.de (Ulrike Fischer)
Newsgroups: comp.text.tex
Subject: Re: beamer warsawtheme: header navigation is off by 1
Date: Mon, 2 May 2022 09:18:03 +0200
Lines: 30
Message-ID: <ad3bgpyx23m0$.dlg@nililand.de>
References: <851qxdnl7w.fsf@gmail.com> <626F0976.3B959195@Berger-Odenthal.De> <85sfpsmy4c.fsf@gmail.com>
Reply-To: news3@nililand.de
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
X-Trace: individual.net 5mPDAv4WXS2y0I1Yt4IVPAVL6+/k8bU/Mn3gqQmzjojj5N2Fhx
Cancel-Lock: sha1:qh8dV6roZ9IplHvlIgiDU4StR78=
User-Agent: 40tude_Dialog/2.0.15.41de
View all headers
Am Mon, 02 May 2022 08:36:43 +0530 schrieb Sivaram Neelakantan:

On Mon, May 02 2022,Axel Berger wrote:

Sivaram Neelakantan wrote:
Also I use \include immediately under \section

Try \input. I'm surprised \include works here at all.

it does work (but is imho seldom useful in a presentation). But as
with other documents you have to take care to put everything that
writes to the aux e.g. an \addcontentsline *inside* the include.

So the \section shouldn't be before the \include.

Thank you!  It got fixed.  I've been using \include via auctex as it
seems to give the right prompts to include other tex files.  A quick
check on google shows this

https://tex.stackexchange.com/questions/246/when-should-i-use-input-vs-include

which doesn't seem to show anything that would cause this issue.  What
was going on then?


https://tex.stackexchange.com/q/330427/2388

--
Ulrike Fischer
http://www.troubleshooting-tex.de/


Subject: Re: beamer warsawtheme: header navigation is off by 1
From: Axel Berger
Newsgroups: comp.text.tex
Date: Mon, 2 May 2022 13:44 UTC
References: 1 2 3 4
Path: i2pn2.org!i2pn.org!news.swapon.de!fu-berlin.de!uni-berlin.de!individual.net!not-for-mail
From: Spa...@Berger-Odenthal.De (Axel Berger)
Newsgroups: comp.text.tex
Subject: Re: beamer warsawtheme: header navigation is off by 1
Date: Mon, 02 May 2022 15:44:58 +0200
Lines: 15
Message-ID: <626FE05A.F23CCF68@Berger-Odenthal.De>
References: <851qxdnl7w.fsf@gmail.com> <626F0976.3B959195@Berger-Odenthal.De> <85sfpsmy4c.fsf@gmail.com> <ad3bgpyx23m0$.dlg@nililand.de>
Mime-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: quoted-printable
X-Trace: individual.net 6x+Fdestl46JrHziQbm+rAz0DCOxvZaWoei8Xdrgo8zL7RmKAJ
Cancel-Lock: sha1:jLJhhKfXX3q7oSrnVjV2/tll00w=
X-Mailer: Mozilla 4.8 [en] (Win98; U)
X-Accept-Language: en,de,nl,es,fr
View all headers
Ulrike Fischer wrote:
it does work (but is imho seldom useful in a presentation).

I remember something about it being only to be used for chapters. I'm
not quite sure why that was, one thing is the \cleardoublepage issued.
If that's the only thing, it would probably do no harm in a
presentation.


--
/¯\   No  |    Dipl.-Ing. F. Axel Berger    Tel: +49/ 221/ 7771 8067
\ /  HTML |    Roald-Amundsen-Straße 2a     Fax: +49/ 221/ 7771 8069
 X    in  |    D-50829 Köln-Ossendorf      http://berger-odenthal.de
/ \  Mail | -- No unannounced, large, binary attachments, please! --


Subject: Re: beamer warsawtheme: header navigation is off by 1
From: Sivaram Neelakantan
Newsgroups: comp.text.tex
Organization: A noiseless patient Spider
Date: Mon, 2 May 2022 17:40 UTC
References: 1 2 3 4
Path: i2pn2.org!i2pn.org!eternal-september.org!reader02.eternal-september.org!.POSTED!not-for-mail
From: nsivaram...@gmail.com (Sivaram Neelakantan)
Newsgroups: comp.text.tex
Subject: Re: beamer warsawtheme: header navigation is off by 1
Date: Mon, 02 May 2022 23:10:00 +0530
Organization: A noiseless patient Spider
Lines: 28
Message-ID: <85o80fn89b.fsf@gmail.com>
References: <851qxdnl7w.fsf@gmail.com> <626F0976.3B959195@Berger-Odenthal.De>
<85sfpsmy4c.fsf@gmail.com> <ad3bgpyx23m0$.dlg@nililand.de>
MIME-Version: 1.0
Content-Type: text/plain
Injection-Info: reader02.eternal-september.org; posting-host="683c7d1c30f9fe06f6b40a2b86ab9b93";
logging-data="17671"; mail-complaints-to="abuse@eternal-september.org"; posting-account="U2FsdGVkX19oV5EGHxjGAo6UGqh7IhJHBef6t5Tt9Po="
User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (windows-nt)
Cancel-Lock: sha1:PdVOVWuOY5dGgnXUMWQ7FzMLHqk=
sha1:tA2vZA2jpTrLAYboAIkhSXhYWNo=
User-Mail-Address: nsivaram.net@gmail.com
View all headers
On Mon, May 02 2022,Ulrike Fischer wrote:

Am Mon, 02 May 2022 08:36:43 +0530 schrieb Sivaram Neelakantan:

On Mon, May 02 2022,Axel Berger wrote:

Sivaram Neelakantan wrote:
Also I use \include immediately under \section

Try \input. I'm surprised \include works here at all.

it does work (but is imho seldom useful in a presentation). But as
with other documents you have to take care to put everything that
writes to the aux e.g. an \addcontentsline *inside* the include.

So the \section shouldn't be before the \include.


[snipped 9 lines]


https://tex.stackexchange.com/q/330427/2388

Thanks, that helped.


sivaram
--


Subject: Re: beamer warsawtheme: header navigation is off by 1
From: Sivaram Neelakantan
Newsgroups: comp.text.tex
Organization: A noiseless patient Spider
Date: Mon, 9 May 2022 17:21 UTC
References: 1 2 3 4
Path: i2pn2.org!i2pn.org!eternal-september.org!reader02.eternal-september.org!.POSTED!not-for-mail
From: nsivaram...@gmail.com (Sivaram Neelakantan)
Newsgroups: comp.text.tex
Subject: Re: beamer warsawtheme: header navigation is off by 1
Date: Mon, 09 May 2022 22:51:31 +0530
Organization: A noiseless patient Spider
Lines: 24
Message-ID: <85y1zalizo.fsf@gmail.com>
References: <851qxdnl7w.fsf@gmail.com> <626F0976.3B959195@Berger-Odenthal.De>
<85sfpsmy4c.fsf@gmail.com> <ad3bgpyx23m0$.dlg@nililand.de>
MIME-Version: 1.0
Content-Type: text/plain
Injection-Info: reader02.eternal-september.org; posting-host="da012a8768cbf58264704043d239a5a9";
logging-data="32497"; mail-complaints-to="abuse@eternal-september.org"; posting-account="U2FsdGVkX1+q9jl73G+1D1hHu+uGiPrEf8wm9JjDFRQ="
User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (windows-nt)
Cancel-Lock: sha1:CTEgOjXRtWxr3YgCpcxlD8QlPGo=
sha1:MRD/Fg0+16Iwggl09F5B/RKY+EI=
User-Mail-Address: nsivaram.net@gmail.com
View all headers
On Mon, May 02 2022,Ulrike Fischer wrote:


[snipped 14 lines]


Thank you!  It got fixed.  I've been using \include via auctex as it
seems to give the right prompts to include other tex files.  A quick
check on google shows this

https://tex.stackexchange.com/questions/246/when-should-i-use-input-vs-include

which doesn't seem to show anything that would cause this issue.  What
was going on then?


https://tex.stackexchange.com/q/330427/2388

A minor update to using \input in Emacs + auctex + reftex is that, the
scanning to build the TOC within Emacs takes a visible few seconds
compared to \include.  It's not annoying but definitely noticable.

sivaram
--


1
rocksolid light 0.7.2
clearneti2ptor