Rocksolid Light

Welcome to novaBBS (click a section below)

mail  files  register  newsreader  groups  login

Message-ID:  

An authority is a person who can tell you more about something than you really care to know.


devel / comp.unix.bsd.freebsd.misc / Re: X Not Launching & Fix No Longer Works

SubjectAuthor
* X Not Launching & Fix No Longer WorksLouis Epstein
`* Re: X Not Launching & Fix No Longer WorksLouis Epstein
 `* Re: X Not Launching & Fix No Longer WorksAlastair Hogge
  `* Re: X Not Launching & Fix No Longer WorksLouis Epstein
   `* Re: X Not Launching & Fix No Longer WorksAlastair Hogge
    `* Re: X Not Launching & Fix No Longer WorksLouis Epstein
     `* Re: X Not Launching & Fix No Longer WorksLouis Epstein
      `- Re: X Not Launching & Fix No Longer WorksLouis Epstein

1
X Not Launching & Fix No Longer Works

<uauk0l$7ru$1@reader2.panix.com>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=418&group=comp.unix.bsd.freebsd.misc#418

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.12.144.5.2!not-for-mail
From: le...@main.lekno.ws (Louis Epstein)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: X Not Launching & Fix No Longer Works
Date: Tue, 8 Aug 2023 23:44:21 -0000 (UTC)
Organization: PANIX Public Access Internet and UNIX, NYC
Message-ID: <uauk0l$7ru$1@reader2.panix.com>
Injection-Date: Tue, 8 Aug 2023 23:44:21 -0000 (UTC)
Injection-Info: reader2.panix.com; posting-host="12.144.5.2";
logging-data="8062"; mail-complaints-to="abuse@panix.com"
User-Agent: tin/2.6.2-20221225 ("Pittyvaich") (FreeBSD/12.4-RELEASE-p4 (amd64))
 by: Louis Epstein - Tue, 8 Aug 2023 23:44 UTC

I posted a couple of months ago when I still had a workaround.

My startx file was generating some error messages on attempts
to launch X,with MESA-LOADER: reporting

failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so" (search paths /usr/local/lib/dri, suffix _dri)
failed to load driver: radeon

amid more general

failed to retrieve device information

messages.
This is interspersed with

kmsro: driver missing

and led to

Fatal server error:
(EE) AddScreen/ScreenInit failed for gpu driver 0 -1

copying a radeon_dri.so into /usr/local/lib/dri (which does have a radeonsi_dri.so in it)

would change the "Cannot open..." message into another "failed to retrieve device information"
followed by

unknown chip id 0x683d, can't guess.

(The same fatal server error would ensue).

Until now I could get things working again by deleting and reinstalling xorg and xorg-server
but now apparently the older version of xorg-server (21.1.7 something) no longer gets installed
by pkg install and the new version 21.1.8_2 is the only one available and is not compatible.

A lot of amdgpu firmware packages just got updated though I assume only the one for my card
would be called on.

-=-=-
The World Trade Center towers MUST rise again,
at least as tall as before...or terror has triumphed.

Re: X Not Launching & Fix No Longer Works

<uaur2i$onj$1@reader2.panix.com>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=419&group=comp.unix.bsd.freebsd.misc#419

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.12.144.5.2!not-for-mail
From: le...@main.lekno.ws (Louis Epstein)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: Re: X Not Launching & Fix No Longer Works
Date: Wed, 9 Aug 2023 01:44:50 -0000 (UTC)
Organization: PANIX Public Access Internet and UNIX, NYC
Message-ID: <uaur2i$onj$1@reader2.panix.com>
References: <uauk0l$7ru$1@reader2.panix.com>
Injection-Date: Wed, 9 Aug 2023 01:44:50 -0000 (UTC)
Injection-Info: reader2.panix.com; posting-host="12.144.5.2";
logging-data="25331"; mail-complaints-to="abuse@panix.com"
User-Agent: tin/2.6.2-20221225 ("Pittyvaich") (FreeBSD/12.4-RELEASE-p4 (amd64))
 by: Louis Epstein - Wed, 9 Aug 2023 01:44 UTC

Louis Epstein <le@main.lekno.ws> wrote:
> I posted a couple of months ago when I still had a workaround.
>
> My startx file was generating some error messages on attempts
> to launch X,with MESA-LOADER: reporting
>
> failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so" (search paths /usr/local/lib/dri, suffix _dri)
> failed to load driver: radeon
>
> amid more general
>
> failed to retrieve device information
>
> messages.
> This is interspersed with
>
> kmsro: driver missing
>
> and led to
>
> Fatal server error:
> (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
>
>
>
> copying a radeon_dri.so into /usr/local/lib/dri (which does have a radeonsi_dri.so in it)
>
> would change the "Cannot open..." message into another "failed to retrieve device information"
> followed by
>
> unknown chip id 0x683d, can't guess.
>
> (The same fatal server error would ensue).
>
> Until now I could get things working again by deleting and reinstalling xorg and xorg-server
> but now apparently the older version of xorg-server (21.1.7 something) no longer gets installed
> by pkg install and the new version 21.1.8_2 is the only one available and is not compatible.
>
> A lot of amdgpu firmware packages just got updated though I assume only the one for my card
> would be called on.

(Not only my startx file that launches fvwm fails to launch...trying
xinit openttd
to launch the game fails with the same error messages on unknown chip).


> -=-=-
> The World Trade Center towers MUST rise again,
> at least as tall as before...or terror has triumphed.

Re: X Not Launching & Fix No Longer Works

<ub1edb$4aio$1@dont-email.me>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=420&group=comp.unix.bsd.freebsd.misc#420

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!eternal-september.org!news.eternal-september.org!.POSTED.199.90.70.115.static.exetel.com.au!not-for-mail
From: agh...@riseup.net (Alastair Hogge)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: Re: X Not Launching & Fix No Longer Works
Date: Thu, 10 Aug 2023 01:27:08 -0000 (UTC)
Organization: A noiseless patient Spider
Message-ID: <ub1edb$4aio$1@dont-email.me>
References: <uauk0l$7ru$1@reader2.panix.com> <uaur2i$onj$1@reader2.panix.com>
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Injection-Date: Thu, 10 Aug 2023 01:27:08 -0000 (UTC)
Injection-Info: dont-email.me; posting-host="199.90.70.115.static.exetel.com.au:115.70.90.199";
logging-data="141912"; mail-complaints-to="abuse@eternal-september.org"
User-Agent: Pan/0.145 (Duplicitous mercenary valetism; d7e168a
git.gnome.org/pan2)
 by: Alastair Hogge - Thu, 10 Aug 2023 01:27 UTC

On Wed, 09 Aug 2023 01:44:50 +0000, Louis Epstein wrote:

> Louis Epstein <le@main.lekno.ws> wrote:
>> I posted a couple of months ago when I still had a workaround.
>>
>> My startx file was generating some error messages on attempts to launch
>> X,with MESA-LOADER: reporting
>>
>> failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so"
>> (search paths /usr/local/lib/dri, suffix _dri)
>> failed to load driver: radeon
>>
>> amid more general
>>
>> failed to retrieve device information
>>
>> messages.
>> This is interspersed with
>>
>> kmsro: driver missing
>>
>> and led to
>>
>> Fatal server error:
>> (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
>>
>>
>>
>> copying a radeon_dri.so into /usr/local/lib/dri (which does have a
>> radeonsi_dri.so in it)
>>
>> would change the "Cannot open..." message into another "failed to
>> retrieve device information"
>> followed by
>>
>> unknown chip id 0x683d, can't guess.
>>
>> (The same fatal server error would ensue).
>>
>> Until now I could get things working again by deleting and reinstalling
>> xorg and xorg-server but now apparently the older version of
>> xorg-server (21.1.7 something) no longer gets installed by pkg install
>> and the new version 21.1.8_2 is the only one available and is not
>> compatible.
>>
>> A lot of amdgpu firmware packages just got updated though I assume only
>> the one for my card would be called on.
>
> (Not only my startx file that launches fvwm fails to launch...trying
> xinit openttd to launch the game fails with the same error messages on
> unknown chip).

My gosh, on an initial glance, it looks like you have mismatched base and
Ports, or there some pkg's are out of sync between X, the graphics stack,
and your base.

--
To health and anarchy

Re: X Not Launching & Fix No Longer Works

<ub1kho$g5h$1@reader2.panix.com>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=421&group=comp.unix.bsd.freebsd.misc#421

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.12.144.5.2!not-for-mail
From: le...@main.lekno.ws (Louis Epstein)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: Re: X Not Launching & Fix No Longer Works
Date: Thu, 10 Aug 2023 03:11:52 -0000 (UTC)
Organization: PANIX Public Access Internet and UNIX, NYC
Message-ID: <ub1kho$g5h$1@reader2.panix.com>
References: <uauk0l$7ru$1@reader2.panix.com> <uaur2i$onj$1@reader2.panix.com> <ub1edb$4aio$1@dont-email.me>
Injection-Date: Thu, 10 Aug 2023 03:11:52 -0000 (UTC)
Injection-Info: reader2.panix.com; posting-host="12.144.5.2";
logging-data="16561"; mail-complaints-to="abuse@panix.com"
User-Agent: tin/2.6.2-20221225 ("Pittyvaich") (FreeBSD/12.4-RELEASE-p4 (amd64))
 by: Louis Epstein - Thu, 10 Aug 2023 03:11 UTC

Alastair Hogge <agh@riseup.net> wrote:
> On Wed, 09 Aug 2023 01:44:50 +0000, Louis Epstein wrote:
>
>> Louis Epstein <le@main.lekno.ws> wrote:
>>> I posted a couple of months ago when I still had a workaround.
>>>
>>> My startx file was generating some error messages on attempts to launch
>>> X,with MESA-LOADER: reporting
>>>
>>> failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so"
>>> (search paths /usr/local/lib/dri, suffix _dri)
>>> failed to load driver: radeon
>>>
>>> amid more general
>>>
>>> failed to retrieve device information
>>>
>>> messages.
>>> This is interspersed with
>>>
>>> kmsro: driver missing
>>>
>>> and led to
>>>
>>> Fatal server error:
>>> (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
>>>
>>>
>>>
>>> copying a radeon_dri.so into /usr/local/lib/dri (which does have a
>>> radeonsi_dri.so in it)
>>>
>>> would change the "Cannot open..." message into another "failed to
>>> retrieve device information"
>>> followed by
>>>
>>> unknown chip id 0x683d, can't guess.
>>>
>>> (The same fatal server error would ensue).
>>>
>>> Until now I could get things working again by deleting and reinstalling
>>> xorg and xorg-server but now apparently the older version of
>>> xorg-server (21.1.7 something) no longer gets installed by pkg install
>>> and the new version 21.1.8_2 is the only one available and is not
>>> compatible.
>>>
>>> A lot of amdgpu firmware packages just got updated though I assume only
>>> the one for my card would be called on.
>>
>> (Not only my startx file that launches fvwm fails to launch...trying
>> xinit openttd to launch the game fails with the same error messages on
>> unknown chip).
>
> My gosh, on an initial glance, it looks like you have mismatched base and
> Ports, or there some pkg's are out of sync between X, the graphics stack,
> and your base.
>

I am ordinarily upgrading by way of pulling ports from git,
doing a synth prepare-system,
and a pkg upgrade -r Synth.

I am running 12.4-RELEASE-p4.

pixman is 0.42.2

Any suggestions?

-=-=-
The World Trade Center towers MUST rise again,
at least as tall as before...or terror has triumphed.

Re: X Not Launching & Fix No Longer Works

<ub2ci2$4aio$3@dont-email.me>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=422&group=comp.unix.bsd.freebsd.misc#422

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!eternal-september.org!news.eternal-september.org!.POSTED.199.90.70.115.static.exetel.com.au!not-for-mail
From: agh...@riseup.net (Alastair Hogge)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: Re: X Not Launching & Fix No Longer Works
Date: Thu, 10 Aug 2023 10:01:39 -0000 (UTC)
Organization: A noiseless patient Spider
Message-ID: <ub2ci2$4aio$3@dont-email.me>
References: <uauk0l$7ru$1@reader2.panix.com> <uaur2i$onj$1@reader2.panix.com>
<ub1edb$4aio$1@dont-email.me> <ub1kho$g5h$1@reader2.panix.com>
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Injection-Date: Thu, 10 Aug 2023 10:01:39 -0000 (UTC)
Injection-Info: dont-email.me; posting-host="199.90.70.115.static.exetel.com.au:115.70.90.199";
logging-data="141912"; mail-complaints-to="abuse@eternal-september.org"
User-Agent: Pan/0.145 (Duplicitous mercenary valetism; d7e168a
git.gnome.org/pan2)
 by: Alastair Hogge - Thu, 10 Aug 2023 10:01 UTC

On Thu, 10 Aug 2023 03:11:52 +0000, Louis Epstein wrote:

> Alastair Hogge <agh@riseup.net> wrote:
>> On Wed, 09 Aug 2023 01:44:50 +0000, Louis Epstein wrote:
>>
>>> Louis Epstein <le@main.lekno.ws> wrote:
>>>> I posted a couple of months ago when I still had a workaround.
>>>>
>>>> My startx file was generating some error messages on attempts to
>>>> launch X,with MESA-LOADER: reporting
>>>>
>>>> failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so"
>>>> (search paths /usr/local/lib/dri, suffix _dri)
>>>> failed to load driver: radeon
>>>>
>>>> amid more general
>>>>
>>>> failed to retrieve device information
>>>>
>>>> messages.
>>>> This is interspersed with
>>>>
>>>> kmsro: driver missing
>>>>
>>>> and led to
>>>>
>>>> Fatal server error:
>>>> (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
>>>>
>>>>
>>>>
>>>> copying a radeon_dri.so into /usr/local/lib/dri (which does have a
>>>> radeonsi_dri.so in it)
>>>>
>>>> would change the "Cannot open..." message into another "failed to
>>>> retrieve device information"
>>>> followed by
>>>>
>>>> unknown chip id 0x683d, can't guess.
>>>>
>>>> (The same fatal server error would ensue).
>>>>
>>>> Until now I could get things working again by deleting and
>>>> reinstalling xorg and xorg-server but now apparently the older
>>>> version of xorg-server (21.1.7 something) no longer gets installed by
>>>> pkg install and the new version 21.1.8_2 is the only one available
>>>> and is not compatible.
>>>>
>>>> A lot of amdgpu firmware packages just got updated though I assume
>>>> only the one for my card would be called on.
>>>
>>> (Not only my startx file that launches fvwm fails to launch...trying
>>> xinit openttd to launch the game fails with the same error messages on
>>> unknown chip).
>>
>> My gosh, on an initial glance, it looks like you have mismatched base
>> and Ports, or there some pkg's are out of sync between X, the graphics
>> stack,
>> and your base.
>>
>>
> I am ordinarily upgrading by way of pulling ports from git,
> doing a synth prepare-system,
> and a pkg upgrade -r Synth.
>
> I am running 12.4-RELEASE-p4.

12.4 is probably your problem.
> pixman is 0.42.2
>
> Any suggestions?

Switch to 13 or 14 if you can, maintaining packages on 12.4 while trying
to drive a AMD Radeon GPU sounds like a world of pain, graphics/drm-510-
kmod is only compatible with FreeBSD => 13.1, and the for time being, the
latest GPU kernel drivers are in Ports.

--
To health and anarchy

Re: X Not Launching & Fix No Longer Works

<ub3qjh$910$1@reader2.panix.com>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=423&group=comp.unix.bsd.freebsd.misc#423

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.12.144.5.2!not-for-mail
From: le...@main.lekno.ws (Louis Epstein)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: Re: X Not Launching & Fix No Longer Works
Date: Thu, 10 Aug 2023 23:07:29 -0000 (UTC)
Organization: PANIX Public Access Internet and UNIX, NYC
Message-ID: <ub3qjh$910$1@reader2.panix.com>
References: <uauk0l$7ru$1@reader2.panix.com> <uaur2i$onj$1@reader2.panix.com> <ub1edb$4aio$1@dont-email.me> <ub1kho$g5h$1@reader2.panix.com> <ub2ci2$4aio$3@dont-email.me>
Injection-Date: Thu, 10 Aug 2023 23:07:29 -0000 (UTC)
Injection-Info: reader2.panix.com; posting-host="12.144.5.2";
logging-data="9248"; mail-complaints-to="abuse@panix.com"
User-Agent: tin/2.6.2-20221225 ("Pittyvaich") (FreeBSD/12.4-RELEASE-p4 (amd64))
 by: Louis Epstein - Thu, 10 Aug 2023 23:07 UTC

Alastair Hogge <agh@riseup.net> wrote:
> On Thu, 10 Aug 2023 03:11:52 +0000, Louis Epstein wrote:
>
>> Alastair Hogge <agh@riseup.net> wrote:
>>> On Wed, 09 Aug 2023 01:44:50 +0000, Louis Epstein wrote:
>>>
>>>> Louis Epstein <le@main.lekno.ws> wrote:
>>>>> I posted a couple of months ago when I still had a workaround.
>>>>>
>>>>> My startx file was generating some error messages on attempts to
>>>>> launch X,with MESA-LOADER: reporting
>>>>>
>>>>> failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so"
>>>>> (search paths /usr/local/lib/dri, suffix _dri)
>>>>> failed to load driver: radeon
>>>>>
>>>>> amid more general
>>>>>
>>>>> failed to retrieve device information
>>>>>
>>>>> messages.
>>>>> This is interspersed with
>>>>>
>>>>> kmsro: driver missing
>>>>>
>>>>> and led to
>>>>>
>>>>> Fatal server error:
>>>>> (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
>>>>>
>>>>>
>>>>>
>>>>> copying a radeon_dri.so into /usr/local/lib/dri (which does have a
>>>>> radeonsi_dri.so in it)
>>>>>
>>>>> would change the "Cannot open..." message into another "failed to
>>>>> retrieve device information"
>>>>> followed by
>>>>>
>>>>> unknown chip id 0x683d, can't guess.
>>>>>
>>>>> (The same fatal server error would ensue).
>>>>>
>>>>> Until now I could get things working again by deleting and
>>>>> reinstalling xorg and xorg-server but now apparently the older
>>>>> version of xorg-server (21.1.7 something) no longer gets installed by
>>>>> pkg install and the new version 21.1.8_2 is the only one available
>>>>> and is not compatible.
>>>>>
>>>>> A lot of amdgpu firmware packages just got updated though I assume
>>>>> only the one for my card would be called on.
>>>>
>>>> (Not only my startx file that launches fvwm fails to launch...trying
>>>> xinit openttd to launch the game fails with the same error messages on
>>>> unknown chip).
>>>
>>> My gosh, on an initial glance, it looks like you have mismatched base
>>> and Ports, or there some pkg's are out of sync between X, the graphics
>>> stack,
>>> and your base.
>>>
>>>
>> I am ordinarily upgrading by way of pulling ports from git,
>> doing a synth prepare-system,
>> and a pkg upgrade -r Synth.
>>
>> I am running 12.4-RELEASE-p4.
>
> 12.4 is probably your problem.
>
>> pixman is 0.42.2
>>
>> Any suggestions?
>
> Switch to 13 or 14 if you can, maintaining packages on 12.4 while trying
> to drive a AMD Radeon GPU sounds like a world of pain, graphics/drm-510-
> kmod is only compatible with FreeBSD => 13.1, and the for time being, the
> latest GPU kernel drivers are in Ports.
>
>

The xorg-server version seems to be what broke things.
I tend to be trailing-edge on my version of the OS...each new version
seems to stop supporting something.

I note that on bootup there's a message saying how drm-kmod
is needed but it was installed last September per pkg info.

-=-=-
The World Trade Center towers MUST rise again,
at least as tall as before...or terror has triumphed.

Re: X Not Launching & Fix No Longer Works

<ubb0vu$j04$1@reader2.panix.com>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=425&group=comp.unix.bsd.freebsd.misc#425

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.12.144.5.2!not-for-mail
From: le...@main.lekno.ws (Louis Epstein)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: Re: X Not Launching & Fix No Longer Works
Date: Sun, 13 Aug 2023 16:39:26 -0000 (UTC)
Organization: PANIX Public Access Internet and UNIX, NYC
Message-ID: <ubb0vu$j04$1@reader2.panix.com>
References: <uauk0l$7ru$1@reader2.panix.com> <uaur2i$onj$1@reader2.panix.com> <ub1edb$4aio$1@dont-email.me> <ub1kho$g5h$1@reader2.panix.com> <ub2ci2$4aio$3@dont-email.me> <ub3qjh$910$1@reader2.panix.com>
Injection-Date: Sun, 13 Aug 2023 16:39:26 -0000 (UTC)
Injection-Info: reader2.panix.com; posting-host="12.144.5.2";
logging-data="19460"; mail-complaints-to="abuse@panix.com"
User-Agent: tin/2.6.2-20221225 ("Pittyvaich") (FreeBSD/12.4-RELEASE-p4 (amd64))
 by: Louis Epstein - Sun, 13 Aug 2023 16:39 UTC

Louis Epstein <le@main.lekno.ws> wrote:
> Alastair Hogge <agh@riseup.net> wrote:
>> On Thu, 10 Aug 2023 03:11:52 +0000, Louis Epstein wrote:
>>
>>> Alastair Hogge <agh@riseup.net> wrote:
>>>> On Wed, 09 Aug 2023 01:44:50 +0000, Louis Epstein wrote:
>>>>
>>>>> Louis Epstein <le@main.lekno.ws> wrote:
>>>>>> I posted a couple of months ago when I still had a workaround.
>>>>>>
>>>>>> My startx file was generating some error messages on attempts to
>>>>>> launch X,with MESA-LOADER: reporting
>>>>>>
>>>>>> failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so"
>>>>>> (search paths /usr/local/lib/dri, suffix _dri)
>>>>>> failed to load driver: radeon
>>>>>>
>>>>>> amid more general
>>>>>>
>>>>>> failed to retrieve device information
>>>>>>
>>>>>> messages.
>>>>>> This is interspersed with
>>>>>>
>>>>>> kmsro: driver missing
>>>>>>
>>>>>> and led to
>>>>>>
>>>>>> Fatal server error:
>>>>>> (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
>>>>>>
>>>>>>
>>>>>>
>>>>>> copying a radeon_dri.so into /usr/local/lib/dri (which does have a
>>>>>> radeonsi_dri.so in it)
>>>>>>
>>>>>> would change the "Cannot open..." message into another "failed to
>>>>>> retrieve device information"
>>>>>> followed by
>>>>>>
>>>>>> unknown chip id 0x683d, can't guess.
>>>>>>
>>>>>> (The same fatal server error would ensue).
>>>>>>
>>>>>> Until now I could get things working again by deleting and
>>>>>> reinstalling xorg and xorg-server but now apparently the older
>>>>>> version of xorg-server (21.1.7 something) no longer gets installed by
>>>>>> pkg install and the new version 21.1.8_2 is the only one available
>>>>>> and is not compatible.
>>>>>>
>>>>>> A lot of amdgpu firmware packages just got updated though I assume
>>>>>> only the one for my card would be called on.
>>>>>
>>>>> (Not only my startx file that launches fvwm fails to launch...trying
>>>>> xinit openttd to launch the game fails with the same error messages on
>>>>> unknown chip).
>>>>
>>>> My gosh, on an initial glance, it looks like you have mismatched base
>>>> and Ports, or there some pkg's are out of sync between X, the graphics
>>>> stack,
>>>> and your base.
>>>>
>>>>
>>> I am ordinarily upgrading by way of pulling ports from git,
>>> doing a synth prepare-system,
>>> and a pkg upgrade -r Synth.
>>>
>>> I am running 12.4-RELEASE-p4.
>>
>> 12.4 is probably your problem.
>>
>>> pixman is 0.42.2
>>>
>>> Any suggestions?
>>
>> Switch to 13 or 14 if you can, maintaining packages on 12.4 while trying
>> to drive a AMD Radeon GPU sounds like a world of pain, graphics/drm-510-
>> kmod is only compatible with FreeBSD => 13.1, and the for time being, the
>> latest GPU kernel drivers are in Ports.
>>
>>
>
> The xorg-server version seems to be what broke things.

21.1.8_4 has since emerged and doesn't work either.

> I tend to be trailing-edge on my version of the OS...each new version
> seems to stop supporting something.

(No idea if 13.x would be harder on Seamonkey?)
> I note that on bootup there's a message saying how drm-kmod
> is needed but it was installed last September per pkg info.
>
> -=-=-
> The World Trade Center towers MUST rise again,
> at least as tall as before...or terror has triumphed.

Re: X Not Launching & Fix No Longer Works

<ubhths$e2v$1@reader2.panix.com>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=426&group=comp.unix.bsd.freebsd.misc#426

  copy link   Newsgroups: comp.unix.bsd.freebsd.misc
Path: i2pn2.org!i2pn.org!weretis.net!feeder6.news.weretis.net!panix!.POSTED.12.144.5.2!not-for-mail
From: le...@main.lekno.ws (Louis Epstein)
Newsgroups: comp.unix.bsd.freebsd.misc
Subject: Re: X Not Launching & Fix No Longer Works
Date: Wed, 16 Aug 2023 07:23:40 -0000 (UTC)
Organization: PANIX Public Access Internet and UNIX, NYC
Message-ID: <ubhths$e2v$1@reader2.panix.com>
References: <uauk0l$7ru$1@reader2.panix.com> <uaur2i$onj$1@reader2.panix.com> <ub1edb$4aio$1@dont-email.me> <ub1kho$g5h$1@reader2.panix.com> <ub2ci2$4aio$3@dont-email.me> <ub3qjh$910$1@reader2.panix.com> <ubb0vu$j04$1@reader2.panix.com>
Injection-Date: Wed, 16 Aug 2023 07:23:40 -0000 (UTC)
Injection-Info: reader2.panix.com; posting-host="12.144.5.2";
logging-data="14431"; mail-complaints-to="abuse@panix.com"
User-Agent: tin/2.6.2-20221225 ("Pittyvaich") (FreeBSD/13.2-RELEASE-p2 (amd64))
 by: Louis Epstein - Wed, 16 Aug 2023 07:23 UTC

Louis Epstein <le@main.lekno.ws> wrote:
> Louis Epstein <le@main.lekno.ws> wrote:
>> Alastair Hogge <agh@riseup.net> wrote:
>>> On Thu, 10 Aug 2023 03:11:52 +0000, Louis Epstein wrote:
>>>
>>>> Alastair Hogge <agh@riseup.net> wrote:
>>>>> On Wed, 09 Aug 2023 01:44:50 +0000, Louis Epstein wrote:
>>>>>
>>>>>> Louis Epstein <le@main.lekno.ws> wrote:
>>>>>>> I posted a couple of months ago when I still had a workaround.
>>>>>>>
>>>>>>> My startx file was generating some error messages on attempts to
>>>>>>> launch X,with MESA-LOADER: reporting
>>>>>>>
>>>>>>> failed to open radeon: Cannot open "usr/local/lib/dri/radeon_dri.so"
>>>>>>> (search paths /usr/local/lib/dri, suffix _dri)
>>>>>>> failed to load driver: radeon
>>>>>>>
>>>>>>> amid more general
>>>>>>>
>>>>>>> failed to retrieve device information
>>>>>>>
>>>>>>> messages.
>>>>>>> This is interspersed with
>>>>>>>
>>>>>>> kmsro: driver missing
>>>>>>>
>>>>>>> and led to
>>>>>>>
>>>>>>> Fatal server error:
>>>>>>> (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> copying a radeon_dri.so into /usr/local/lib/dri (which does have a
>>>>>>> radeonsi_dri.so in it)
>>>>>>>
>>>>>>> would change the "Cannot open..." message into another "failed to
>>>>>>> retrieve device information"
>>>>>>> followed by
>>>>>>>
>>>>>>> unknown chip id 0x683d, can't guess.
>>>>>>>
>>>>>>> (The same fatal server error would ensue).
>>>>>>>
>>>>>>> Until now I could get things working again by deleting and
>>>>>>> reinstalling xorg and xorg-server but now apparently the older
>>>>>>> version of xorg-server (21.1.7 something) no longer gets installed by
>>>>>>> pkg install and the new version 21.1.8_2 is the only one available
>>>>>>> and is not compatible.
>>>>>>>
>>>>>>> A lot of amdgpu firmware packages just got updated though I assume
>>>>>>> only the one for my card would be called on.
>>>>>>
>>>>>> (Not only my startx file that launches fvwm fails to launch...trying
>>>>>> xinit openttd to launch the game fails with the same error messages on
>>>>>> unknown chip).
>>>>>
>>>>> My gosh, on an initial glance, it looks like you have mismatched base
>>>>> and Ports, or there some pkg's are out of sync between X, the graphics
>>>>> stack,
>>>>> and your base.
>>>>>
>>>>>
>>>> I am ordinarily upgrading by way of pulling ports from git,
>>>> doing a synth prepare-system,
>>>> and a pkg upgrade -r Synth.
>>>>
>>>> I am running 12.4-RELEASE-p4.
>>>
>>> 12.4 is probably your problem.
>>>
>>>> pixman is 0.42.2
>>>>
>>>> Any suggestions?
>>>
>>> Switch to 13 or 14 if you can, maintaining packages on 12.4 while trying
>>> to drive a AMD Radeon GPU sounds like a world of pain, graphics/drm-510-
>>> kmod is only compatible with FreeBSD => 13.1, and the for time being, the
>>> latest GPU kernel drivers are in Ports.
>>>
>>>
>>
>> The xorg-server version seems to be what broke things.
>
> 21.1.8_4 has since emerged and doesn't work either.
>
>
>> I tend to be trailing-edge on my version of the OS...each new version
>> seems to stop supporting something.
>
> (No idea if 13.x would be harder on Seamonkey?)

13.2 and Seamonkey and X are now working today,finally.


>> I note that on bootup there's a message saying how drm-kmod
>> is needed but it was installed last September per pkg info.
>>
>> -=-=-
>> The World Trade Center towers MUST rise again,
>> at least as tall as before...or terror has triumphed.


devel / comp.unix.bsd.freebsd.misc / Re: X Not Launching & Fix No Longer Works

1
server_pubkey.txt

rocksolid light 0.9.81
clearnet tor