Rocksolid Light

Welcome to novaBBS (click a section below)

mail  files  register  newsreader  groups  login

Message-ID:  

Delta: The kids will love our inflatable slides. -- David Letterman


devel / comp.unix.solaris / Solaris 11.3 , comiling OpenLDAP 2.6.2 from source, how to force 64-bin for gnuTLS and Nettle?

SubjectAuthor
o Solaris 11.3 , comiling OpenLDAP 2.6.2 from source, how to forceARZ Lab

1
Solaris 11.3 , comiling OpenLDAP 2.6.2 from source, how to force 64-bin for gnuTLS and Nettle?

<dffe3861-8369-4ad8-9d18-477a494cc15an@googlegroups.com>

  copy mid

https://www.novabbs.com/devel/article-flat.php?id=77&group=comp.unix.solaris#77

  copy link   Newsgroups: comp.unix.solaris
X-Received: by 2002:a05:620a:240a:b0:6a6:b841:a635 with SMTP id d10-20020a05620a240a00b006a6b841a635mr10940038qkn.689.1654691412816;
Wed, 08 Jun 2022 05:30:12 -0700 (PDT)
X-Received: by 2002:a81:802:0:b0:2f7:cd12:9d53 with SMTP id
2-20020a810802000000b002f7cd129d53mr36048780ywi.197.1654691412652; Wed, 08
Jun 2022 05:30:12 -0700 (PDT)
Path: i2pn2.org!rocksolid2!i2pn.org!usenet.blueworldhosting.com!feed1.usenet.blueworldhosting.com!peer02.iad!feed-me.highwinds-media.com!news.highwinds-media.com!news-out.google.com!nntp.google.com!postnews.google.com!google-groups.googlegroups.com!not-for-mail
Newsgroups: comp.unix.solaris
Date: Wed, 8 Jun 2022 05:30:12 -0700 (PDT)
Injection-Info: google-groups.googlegroups.com; posting-host=213.55.225.196; posting-account=1Pu_rwoAAAB2r_mjSonZUZctDy1Suodq
NNTP-Posting-Host: 213.55.225.196
User-Agent: G2/1.0
MIME-Version: 1.0
Message-ID: <dffe3861-8369-4ad8-9d18-477a494cc15an@googlegroups.com>
Subject: Solaris 11.3 , comiling OpenLDAP 2.6.2 from source, how to force
64-bin for gnuTLS and Nettle?
From: andywhyc...@gmail.com (ARZ Lab)
Injection-Date: Wed, 08 Jun 2022 12:30:12 +0000
Content-Type: text/plain; charset="UTF-8"
X-Received-Bytes: 1863
 by: ARZ Lab - Wed, 8 Jun 2022 12:30 UTC

Hello All
I need to replace he bundled slapd 2.4 with a 2.6.2, however, compiling it from source in Solaris takes much more effort than expected.
It obvously requires newer OpenSSL.. and that one wants a newer Perl...
Allright, SSL has been finally compiled and installed in /usr/local.
The libs are 64 bit
Now, OpenLDAP make is asking for new gnuTLS and Nettle libs, and these refuce to compile in 64 bit! Whatever ./configure options I try, they are refused or ignored
../configure --build=solaris_64
../configure --build=solaris-x86_64
../configure --build=solaris64
../configure --build=solaris64-x86_64
../configure --build=solaris64-x86_64-gcc
Before I start wasting hours for cracking the ./configure scripts for both packages, maybe someone can give me a better hint?
Thanks
Andrei


devel / comp.unix.solaris / Solaris 11.3 , comiling OpenLDAP 2.6.2 from source, how to force 64-bin for gnuTLS and Nettle?

1
server_pubkey.txt

rocksolid light 0.9.81
clearnet tor