Rocksolid Light

Welcome to Rocksolid Light

register   nodelist   faq  


rocksolid / rocksolid.shared.rocksolid / Re: I see bugs

SubjectAuthor
* Re: I see bugstrw
+* Re: I see bugsRetro Guy
|`* Re: I see bugsAnonUser
| `* Re: I see bugsRetro Guy
|  `- Re: I see bugsRetro Guy
`- Re: I see bugsRetro Guy

Subject: Re: I see bugs
From: trw@anon.com (trw)
Newsgroups: rocksolid.shared.rocksolid
Organization: def5
Date: Sat, 22 Jun 2019 14:39 UTC

I have not seen that one in ages...
This will go away once I upgrade to the latest sources, right ?

cheers

trw

Posted on def4


Subject: Re: I see bugs
From: retro_guy@retrobbs.rocksolidbbs.com (Retro Guy)
Newsgroups: rocksolid.shared.rocksolid
Organization: novabbs
Date: Sat, 22 Jun 2019 22:35 UTC
On Sat, 22 Jun 2019 14:39:54+0000
trw <trw@anon.com> wrote:


I have not seen that one in ages...
This will go away once I upgrade to the latest sources, right ?


That should already be fixed with some updated files I sent a while
back, but yes, this doesn't happen with the latest source.


--
Posted via novabbs




Subject: Re: I see bugs
From: AnonUser@rslight.anon (AnonUser)
Newsgroups: rocksolid.shared.rocksolid
Organization: Rocksolid Light
Date: Sun, 23 Jun 2019 10:21 UTC
That should already be fixed with some updated files I sent a while
back,

I used those files, too. Maybe the bug wasn't really fixed ?

Btw, cool new colors on http://dkzerogt6z6ybhcj.onion/.

cheers

trw
--
Posted on Rocksolid Light



Subject: Re: I see bugs
From: retro_guy@retrobbs.rocksolidbbs.com (Retro Guy)
Newsgroups: rocksolid.shared.rocksolid
Organization: novabbs
Date: Sun, 23 Jun 2019 22:21 UTC
On Sun, 23 Jun 2019 10:21:42 -0000 (UTC)
AnonUser@rslight.anon (AnonUser) wrote:

That should already be fixed with some updated files I sent a while
back,

I used those files, too. Maybe the bug wasn't really fixed ?

Are you still seeing the bug? The image I sent was from a post in
January.


Btw, cool new colors on http://dkzerogt6z6ybhcj.onion/.


Thanks! Much brighter than before.

--
Posted via novabbs




Subject: Re: I see bugs
From: retro_guy@retrobbs.rocksolidbbs.com (Retro Guy)
Newsgroups: rocksolid.shared.rocksolid
Organization: novabbs
Date: Mon, 24 Jun 2019 05:52 UTC
On Sat, 22 Jun 2019 14:39:54+0000
trw <trw@anon.com> wrote:


I have not seen that one in ages...
This will go away once I upgrade to the latest sources, right ?


The bug should have been fixed pre 0.6.0, so correct, it should not
exist in latest sources.

Notes on upgrading from pre 0.6.0, which is what you have:

1. Config files have been moved to /etc/rslight
   Config file contents have changed (more settings moved to this file)
   A new config file, rslight.inc.php is created for the shell of the
 site. You need both rslight.inc.php and rocksolid.inc.php.
   The file, footer.inc, is no longer required.

2. User data has been moved to /etc/rslight/users
   It's fine to symlink the old location of /var/www/chkpop/users
   to /etc/rslight/users

3. css files moved to common/

How to upgrade from pre 0.6.0:

1. Back up rocksolid/ and common/:

   From web root for rslight (the dir where common/ and rocksolid/
   currently exist)
   mv rocksolid rocksolid.bak
   mv common common.bak

2. From web root for rslight:
   tar zxvf rslight-0.6.x.tgz (use latest available)
   cp rocksolid.bak/groups.txt rocksolid/
   cp rocksolid.bak/style.css common/
   mv rslight /etc/

3. Set permissions:
   The user running the web server must have read/write privileges to:
   rocksolid/spool
   rocksolid/upload
   /etc/rslight/users
   You may symlink users/ to an already existing dir users/, or copy
   the files over.

4. Configure:
   Read and edit /etc/rslight/rocksolid.inc.php
   Read and edit /etc/rslight/rslight.inc.php

That should do it. If there are major problems, you have a nice backup
you can move back into place.

Retro Guy

--
Posted via novabbs




Subject: Re: I see bugs
From: Retro Guy@rslight.anon (Retro Guy)
Newsgroups: rocksolid.shared.rocksolid
Organization: Rocksolid Light
Date: Sat, 29 Jun 2019 06:26 UTC
Retro Guy wrote:

On Sun, 23 Jun 2019 10:21:42 -0000 (UTC)
AnonUser@rslight.anon (AnonUser) wrote:

That should already be fixed with some updated files I sent a while
back,

I used those files, too. Maybe the bug wasn't really fixed ?

Are you still seeing the bug? The image I sent was from a post in
January.

When I "fixed" that bug, I really just disabled the feature, which was to allow incoming links to an article to build the frames for the site.

I'm currently working on a better way to do that and it's working very well. I have not applied to any live sites yet, still just on my test site, but hopefully it will be in the next release.

Retro Guy

--
Posted on Rocksolid Light



1
rocksolid light 0.6.5e
clearnet i2p tor